Project

General

Profile

Bug #951

Trash cleanup (cleartrash.nss) using incorrect timestamps.

Added by Gorgon CCC about 1 month ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Modules Affected:
All
Systems Affected:
Steps to Reproduce:

Description

#924 recently fixed a problem with trash cleanup, where it was using a combination of IG and RL times when calculating when to clean up trash.

datetime2.nss uses IG 20 minute hours when getting the current time, then uses 60 minute hours for comparing it to a saved timestamp, so it causes problems. In most cases, it isn't obvious since cleanup usually happens within 16 minutes, but there are several ways it can cause cleanup to run much earlier than intended.

E.g., If the 20 minute "hour" changed, it would immediately clear anything set after that time, since an hour is supposed to be 60 minutes as far as datetime2 is concerned.

History

#1 Updated by Gorgon CCC about 1 month ago

  • Status changed from New to In Progress

#3 Updated by Hamlet QA & PH about 1 month ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF