Project

General

Profile

Bug #942

Orc Custom Creator - Incorrect Stats

Added by Xeo Player 2 months ago. Updated about 1 month ago.

Status:
In Progress
Priority:
Normal
Modules Affected:
Le'Or T'Nanshi, Underdark
Systems Affected:
Custom Races
Steps to Reproduce:

Description

There is a BUG somewhere on the Custom Race Creator on Le'Or and the Underdark server.

  • The Wiki says http://wiki.avlis.org/Orc +3 STR, -2 DEX and +1 INT
  • Le'Or NPC Custom Race Creator - Both say 2+ STR, -2 DEX and +1 INT

But the actual result is - +1 STR, -2 DEX and +3 INT

I have attached some screenshots.

Gav :)

race_customizer1.jpg (170 KB) race_customizer1.jpg Gorgon CCC, 03/16/2019 09:06 PM

History

#1 Updated by Xeo Player 2 months ago

I cannot attach screen shots but I do have them on my phone and can upload them to Avlis Help on Discord. I've posted some screenies already in general chat.

#2 Updated by Deider DM CCC 2 months ago

  • Status changed from New to Closed

Quoting Gorgon from Discord:
"When choosing Orc as the race, it further modifies it by +1 STR to get the +3 STR, -2 DEX (from the Orc stats) and +3 INT added to the base -2 INT for Half-Orc, for a total of +1 INT (Half-Orcs also get -2 CHA that isn't modified for Orcs). So +1 STR, -2 DEX and +3 INT match your results for Half-Orc to Orc conversion. No bug there."

#3 Updated by Gorgon CCC 2 months ago

Gonna unclose this since there is still the IG bug with what the customizer reports (I can't set it back to "new", so ignore the "In Progress" status for now). I was writing this up when Deider posted his, so it is a tad redundant with the first bit, but the rest is useful.

Xeo Player wrote:

  • The Wiki says http://wiki.avlis.org/Orc +3 STR, -2 DEX and +1 INT
  • Le'Or NPC Custom Race Creator - Both say 2+ STR, -2 DEX and +1 INT

But the actual result is - +1 STR, -2 DEX and +3 INT

Re: Creating custom race characters

Something that MANY people forget, is to take into account the stat modifiers of a base race. If you use a Dwarf, Elf, Gnome, Halfling or Half-Orc, you need to do some math when you assign stats at character creation. EG when creating a Drangonari, which has completely different stat modifiers to the base elf, you have to remember that you will have 2 less dex and 2 more con than is shown when first creating the character.

Orcs use Half-Orc as the base rase, with Ability Score Adjustments:

+2 Str -2 Int -2 Cha
.
When choosing Orc as the race, it further modifies it by +1 STR to get the +3 STR, -2 DEX (from the Orc stats), +3 INT added to the base -2 INT for Half-Orc, for a total of +1 INT, and I'm assuming +2 CHA to zero that from the Half-Orc's -2 CHA.

So +1 STR, -2 DEX and +3 INT match your results for Half-Orc to Orc conversion. No bug there.
 


 
The +2 STR, -2 DEX and +1 INT reported at the custom race creator does sound off though. It is supposed to be +3 STR, -2 DEX and +1 INT overall (or +1 STR, -2 DEX, +3 INT and +2 CHA if only talking about Half-Orc to Orc conversion, which wouldn't make sense).

Note to whoever looks into this fix: The info for these is stored as the name entry on "L404_SUBRACE_DEF_xxx" waypoints in the customizer area. It appears more than just this one needs some updating too (incorrect line wrapping on them, poorly worded/missing feats - if they are meant to be displayed at all, bad descriptions and so on). All of the races probably should be double-checked, since this info is displayed in the conversation to players.

I've attached a copy of Xeo's pic from Discord below, of the menu issue (note also the first line of "feats" being included with stats, and how it uses hard to understand names ["Orctrain" instead of "Battle Training vs. Orcs"]):

#4 Updated by Deider DM CCC about 1 month ago

@Gorgon is this something you plan on fixing, a la the "whoever smelt it dealt it" rule of bug reports? ;)

#5 Updated by Gorgon CCC about 1 month ago

I didn't want to assign it to myself since things are moving pretty slowly on my end as far as backlogged stuff already.

Mostly I was making sure it was reported with as much info as possible since Xeo couldn't do it.

Also available in: Atom PDF