Project

General

Profile

Bug #595

Bash Door Script at Illithids only works one way

Added by Lucidic CCC 7 months ago. Updated 3 days ago.

Status:
In Progress
Priority:
Normal
Modules Affected:
Deglos
Systems Affected:
Area Build
Steps to Reproduce:

1) Go to "Southeastern Deglos, Strange Cave"
2) Bash the first door you come to
3) Notice the message about the DC, bring a character that can beat it
4) Enter the doorway, wait for it to close
5) Bash the door again
6) Note the door tells you that it opens, but doesn't actually open


Description

I wandered into Illithids and bashed the door in. There was obviously a script on the door, it had a DC for me to beat based on STR and I beat it so it opened. The first few fights were hard, so I decided to leave. I triggered the same script, and beat the DC, and got the success message, but the door didn't open.

History

#1 Updated by Calzier CCC 7 months ago

I've had look at this. It's not that it's one-way only, but that the script is inconsistent at opening the door. It will open from both sides, but it also won't open when some of the time that a successful bash is reported.

#2 Updated by Lucidic CCC 7 months ago

Sorry if my information wasn't complete then. I tried more than once. At least three times from the outside I bashed it and it properly opened. At least ten times I bashed it from the inside and it did not open. I had 100% success bashing from the outside and 100% failure from the inside. I'm not saying you're wrong, I just want to clarify that I did put the effort in to reproducing this multiple times before reporting it.

#3 Updated by Calzier CCC 7 months ago

Lucidic CCC wrote:

Sorry if my information wasn't complete then. I tried more than once. At least three times from the outside I bashed it and it properly opened. At least ten times I bashed it from the inside and it did not open. I had 100% success bashing from the outside and 100% failure from the inside. I'm not saying you're wrong, I just want to clarify that I did put the effort in to reproducing this multiple times before reporting it.

Oh, I believe you. It seems really weird behaviour, and I can replicate the multiple attempts to open with it not responding (including it seeming more reluctant from the inside). I even tried tweaking the script - clearing the action queue, delaying the door opening - but to no avail.

#4 Updated by Ambrosia QA/DM 3 days ago

  • Status changed from New to In Progress

Also available in: Atom PDF