Project

General

Profile

Bug #491

Changling change shape when transed to another server.

Added by James White about 1 year ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Modules Affected:
All
Systems Affected:
Shifter Form Customizations
Steps to Reproduce:

I with reproduced this multiple times and even had Muze watch me do such. However for some reason, when Muse created a changeling she could not reproduce the issues.


Description

Every Time Torrinn Goes to another server Via a Trans, he changes form into an elf.
I have even deleted the elf form out of his changeling directory of forms and it still happens.

History

#1 Updated by Grimly CCC about 1 year ago

Can you unequip your inventory and see if this still happens.

Tested by player this is still happening regularly and is not related to equipped inventory.

#2 Updated by Korennya CCC 12 months ago

I can confirm that this is happening on one of my changeling characters. IT reverts to an elf everytime you enter any server. I can even log out as say a dog on wilds, save, exit, then immediately re-enter wilds and i'll be an elf. I noticed.. I changed into a form i hadn't used in ages, when I relogged in with form. I appeared correctly and then about 2 seconds later I changed appearance to an elf. Character portrait doesn't change.

#3 Updated by Korennya CCC 12 months ago

Made some progress on this.. My exported character isn't effected by this on the QA server.

Sephira spawned a horse for me on Visi.

1) I changed to elf, mounted and dismounted the horse. Logged out, then back in. I then changed form to dog, and logged out and back in. Result: after about 5 seconds I changed back to an elf.
2) I changed to dwarf. Logged out and back in.. changed to elf.
3) changed to dwarf. Mounted horse and dismounted. logged out and back in.. stayed a dwarf.
4) chagned to dog. relogged. changed to dwarf.
5) chagned to human. mounted/dismounted then relogged. stayed human.
6) changed to dog. relogged.. changed to human.

The problem seems to be that certain changelings are being forced back into the last mounted form. It's almost as if the pc hide isn't being written that it's unmounted when unmount happens. I think avlis_x3_mod_ent is being fired by avlis_onenter, it's seeing that the PC is still mounted when they're not and reverting their form. But if this was the case, the script looks like it should actually put them back on a horse, but that part doesn't happen. There is diffinately a link here, but I can't localize it. It's also compounded by the fact that I can only get it to happen on the live servers and no QA.

I also spoke with the original bug reporter. They claim that their changeling has never been on a horse. I'm not sold though that the horse scripts aren't part of the problem though after this bit of testing.

Console commands don't appear to be active on the liver server (a good thing). In the bioware script there is a "fix" for this. It involves running x3_fix_horse. Which sets the pc variables to an unmounted state (I think)

#5 Updated by Plethora DM 9 months ago

bumping on behalf of player. Should I get him to rebuild?

#6 Updated by Grimly CCC 9 months ago

@Plethora
the way I understand things...... its a complicated test, which requires a different set-up just for this bug, but the bug has been fixed and is awaiting addition to a QA server for a pass/release.
Regardless of the players wish to rebuild, this issue will eventually be fixed released. Sorry for the delay, ill push the fix again on our end.

#7 Updated by Hamlet QA & PH 8 months ago

  • Status changed from New to Resolved

Also available in: Atom PDF