Project

General

Profile

Bug #131

Items from epchests (and merchant) don't add to character inventory when removed from chest

Added by galen_macbyrne QA over 6 years ago. Updated over 1 year ago.

Status:
In Progress
Priority:
High
Modules Affected:
All
Systems Affected:
Persistent Storage
Steps to Reproduce:

Description

PC: Mirkduil Ellerentar
GSID: galen_macbyrne
Servers checked: Elysia, Wilderness
Location: Avlis Carpentry Enterprises Guildhall (ground floor), Elysia server; ACE Outpost in Port Nireth, Wilderness server
Date/Time: Nov 15, 0300-0500 Eastern US time (GMT-5)

I didn't notice any problems earlier/yesterday (servers checked had recently reset, btw), but just now, tried to add some things into storage and take out other., and the "inhaler" function doesn't seem to work, on epchests that are infinite capacity. I had, both out in PC inventory and in bags, Arboreal Extracts, Marrowroots, Cordials of Might, crypt thing bones, pieces of leather, there were items of such in the storage chests, but it did not work to add items from my inventory - said I had none on me. Tried adding by physically opening chest and dropping in, storage incremented, but it still didn't add in bulk from inventory when I tried again. When I tried to take items out, they removed from listed DB storage quantities, but did not add into my inventory - 20 Dried Black Puddings, 1 Ashen Stars Cascade, 1 Arrow, 1 Branch of Avlissian Poplar, 1 Bronze Arrowhead, and 10 Ethereal potions vanished. Note there was NO server message about items "Vanished in a puff of logical non-existence", which I have seen before in somewhat similar circumstances.

I checked personal room chest too...they don't appear to be affected. Sharah our merchant seems to be borked too; tried buying one Caustic bolt, she takes the 3 gp and bolt quantity decrements, but bolt not added to my inventory. Tried putting a raw spider venom into her appraise bowl (she had one in stock already, since she should be buying them for NH4's plot) - she said she doesn't buy raw spider venom, and it returned to my inventory properly. She bought Paralytic Bolts properly though.

Mirk was wearing his ACE Seal ring some times, other times not - it does not appear to be connected to this happening.

Was unable to take out money from the safe as is proper, but able to add 1 gp. Amount in safe remains confidential.

Inhaler function on a sawhorse checked, that seems to be fine, as is unloading function - items properly loaded and unloaded from/to inventory/bags.

Summary: Items on EPstorage chests (and merchant) can be physically dropped in, but when they come out they vanish.

Also checked in ACE's outpost in Port Nireth, Wilderness Server - same problem seen. When I tried to save character, item count was WAY OFF.
Don't take anything valuable out of the chests until this is fixed, or buy anything from a merchant, I'd say. All the component chests in the workroom are affected thus.

Old bug ID: 53894

Imported from Mantis Bug ID 91.

no_magic_box.jpg (219 KB) no_magic_box.jpg Redmine Admin, 06/28/2016 01:30 PM
still_no_box.jpg (133 KB) still_no_box.jpg Redmine Admin, 06/28/2016 01:30 PM

History

#1 Updated by JollyOrc Player about 3 years ago

GSID: JollyOrc
Character: Janur da Medican
Server: Mikona
Area: The Canvas, Third floor

Just had the same bug happen to me. Tried to retrieve "Janurs Magic Box" from the Armoire in Janurs room in the Canvas and it never showed up in my inventory, nor was there an "Acquired Item:" message in the server log.

The item in question was a magic bag with name & appearance altered.

#2 Updated by tizmo CCC about 3 years ago

I cannot replicate the errors described in this bug report. I have submitted code that does additional error checking and provides additional information to the player when something goes wrong.

Also available in: Atom PDF